Ask a Question
Ask Question Login
Corporate Training
  1. Community
  2. Salesforce
  3. Question
Salesforce

OPENROWSET shutting down SQL Server service, but only running on the server

Asked by Anusha Acharya Apr 22, 2021 2.4K views 1 answer
Share

About this question

When i'm using SSMS from my own machine, normally conected to the server I want to run the query, I can run openrowset to select from an excel file with no problems:SELECT top 10 * FROM OPENROWSET('Microsoft.ACE.OLEDB.12.0','Excel 12.0;Database=D:pathecelFile.xlsx', [Planilha1$]) it retrieves me the result.BUT if I connect with for example remote desktop or remote to the server, and run this query inside it, the server just shuts down: Msg 64, Level 20, State 0, Line 0 A transport-level error has occurred when receiving results from the server. (provider: TCP Provider, error: 0 - The specified network name is no longer available.) I've never seen this. even testing with an excel with 10 rows and 3 columns, the SQL server service just shut down. and running from my machine to the server via SSMS, it never fails.

What could this be? there is nothing useful in the server log. What is sql server openrowset?

Your answer

1 Answer

More Salesforce discussions

Learn & Explore

Free tutorials and interview questions from industry experts — learn the skill, then get ready to prove it.

Latest Salesforce Blogs

Guides, tips and career advice on Salesforce from JanBask experts.